Edgenuity Lms
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 11, 2018 - 12:30 EDT
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Jun 11, 2018 - 12:20 EDT
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS, Edgenuity Student LMS, LMS feature/tool, Edgenuity Login, SSO Login, Genius/SIS).