Edgenuity Network Connectivity Issues
Incident Report for status.edgenuity.com
Resolved
All systems are back to operational status and will continue to monitor for any future events.
Posted about 1 year ago. Mar 14, 2017 - 08:52 PDT
Identified
Edgenuity is currently experiencing network connectivity errors in some areas for both student and educators. Several teams are currently working to help resolve the issue as soon as possible. During this time, you may experience delays when contacting our customer support team.
Posted about 1 year ago. Mar 14, 2017 - 08:02 PDT