Edgenuity Intermittent Access
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 22, 2019 - 16:09 EST
Investigating
We are currently investigating this issue.
Posted 5 months ago. Feb 22, 2019 - 15:39 EST
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS, Edgenuity Student LMS, LMS feature/tool, Edgenuity Login, SSO Login, Genius/SIS, PowerSpeak).