MyPath K-12 Degraded Performance
Incident Report for status.edgenuity.com
Resolved
We are pleased to announce that the MyPath K-12 platform is now functioning normally. We apologize for the problems reported earlier, and are confident that the underlying issue has been fixed.
Posted Sep 01, 2021 - 14:15 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 31, 2021 - 14:34 MST
Investigating
The MyPath K-12 platform is currently experiencing degraded performance.

Students and Educators may experience slowness and errors. A third-party service is experiencing an outage which is directly affecting our products.

Our Operations team is currently engaged and investigating the issue. We apologize for the inconvenience and will provide an update as soon as possible.
Posted Aug 31, 2021 - 13:25 MST
This incident affected: Student and Educator Systems (MyPath K-12).