Edgenuity LMS Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 11 months ago. Sep 04, 2018 - 19:36 EDT
Update
We are continuing to investigate this issue.
Posted 11 months ago. Sep 04, 2018 - 19:36 EDT
Investigating
Edgenuity is currently looking into reports of unexpected errors and is currently investigating this issue.
Posted 11 months ago. Sep 04, 2018 - 19:22 EDT