Foreign Languages
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 10, 2018 - 03:50 MST
Identified
Edgenuity is currently addressing an isolated error that may be experienced in some of our foreign language/PowerSpeak courses.
Posted 2 months ago. Oct 10, 2018 - 03:33 MST
This incident affected: Student and Educator Systems (PowerSpeak).