Edgenuity LMS Slowness
Incident Report for status.edgenuity.com
Resolved
All systems are functioning normally at this time. Thank you for your patience as we see new and unprecedented levels of usage across our platform.
Posted Mar 30, 2020 - 15:29 MST
Update
We are continuing to work on a fix for this issue.
Posted Mar 30, 2020 - 14:02 MST
Identified
At this time, we are experiencing higher than normal volume and seeing some intermittent errors. We are working to resolve these issues.
Posted Mar 30, 2020 - 11:12 MST
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS, Edgenuity Student LMS).