Unexpected Errors Searching for Courses
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 16:15 MST
Investigating
We are investigating "Unexpected Errors" when searching for Edgenuity courses in Canvas.
Posted Jul 30, 2020 - 15:31 MST
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS).