Phone System
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 17, 2019 - 16:52 EDT
Identified
This issue has been identified by our 3rd party provider, Zendesk. Zendesk is working to resolve this issue with inbound and outbound calls.
Posted about 1 month ago. Jul 17, 2019 - 15:44 EDT
Investigating
We are currently investigating an issue where users are unable to connect calls to our customer support.
Posted about 1 month ago. Jul 17, 2019 - 15:23 EDT
This incident affected: General Edgenuity Systems (Edgenuity support line).