Sis Login
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 28, 2018 - 09:27 EDT
Update
We are continuing to investigate this issue.
Posted about 1 year ago. Jun 28, 2018 - 08:42 EDT
Update
We are continuing to investigate this issue.
Posted about 1 year ago. Jun 28, 2018 - 08:17 EDT
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Jun 28, 2018 - 08:16 EDT
Identified
We are currently investigating this issue.
Posted about 1 year ago. Jun 28, 2018 - 08:16 EDT
This incident affected: Student and Educator Systems (Genius/SIS).