MyPath K-5 Login Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Aug 11, 2021 - 21:06 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 11, 2021 - 19:53 MST
Investigating
The MyPath K-5 platform is currently experiencing an outage.

Students and Educators may have difficulty logging in.

Our Operations team is currently engaged and investigating the issue. We apologize for the inconvenience and will provide an update as soon as possible.
Posted Aug 11, 2021 - 19:07 MST
This incident affected: Student and Educator Systems (MyPath K-12).