Edgenuity Courseware Unexpected Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Aug 26, 2020 - 08:31 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2020 - 08:25 MST
Investigating
We are currently investigating this issue.
Posted Aug 26, 2020 - 08:06 MST
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS, Edgenuity Student LMS).