Edgenuity's instance of Genius SIS unavailable
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 14:33 MST
Investigating
We are currently investigating this issue.
Posted Sep 08, 2020 - 12:25 MST
This incident affected: Student and Educator Systems (Genius/SIS).