Foreign Language Courses Not Optimal
Incident Report for status.edgenuity.com
Resolved
Powerspeak has been restored for all Edgenuity users.

If you have any other questions or concerns, please e-mail customersupport@edgenuity.com.



Thank you for your partnership,

The Edgenuity Team
Posted 7 months ago. Feb 28, 2017 - 11:42 MST
Identified
Edgenuity is fully operational however, Edgenuity is currently experiencing intermittent network issues in some Language/PowerSpeak courses. We are aware of the issue and are working to resolve it as quickly as possible.

If you have any questions or concerns, or are experiencing any other technical issues, please e-mail customersupport@edgenuity.com.



Thank you for your patience,

The Edgenuity Team
Posted 7 months ago. Feb 28, 2017 - 10:54 MST
This incident affected: Student and Educator Systems (PowerSpeak).