SIS Slowness
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 15 days ago. Sep 06, 2019 - 11:41 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 15 days ago. Sep 06, 2019 - 11:19 EDT
Identified
An issue with SIS has been identified for educators when trying to load SIS current enrollments where they might encounter slowness.

A hot-fix will be deployed with in the hour and will last approximately 10 mins
Posted 15 days ago. Sep 06, 2019 - 10:37 EDT
This incident affected: Student and Educator Systems (Genius/SIS).