Edgenuity LMS Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 12 months ago. Aug 01, 2018 - 13:24 EDT
Investigating
Edgenuity is currently looking into reports of unexpected errors and is currently investigating this issue.
Posted 12 months ago. Aug 01, 2018 - 11:59 EDT