Edgenuity Courseware Gizmo Activities Issues
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Jan 05, 2021 - 16:19 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2021 - 15:58 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 05, 2021 - 15:38 MST
Investigating
The Edgenuity team is investigating an issue in the Edgenuity courseware affecting the Gizmo activities. Users are unable to load the activities and receive the following errors "This subscription is invalid or has expired. Please contact your account representative". Additional information will be provided as received.
Posted Jan 05, 2021 - 14:25 MST
This incident affected: Student and Educator Systems (Edgenuity Student LMS).