Edgenuity LMS Authentication
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 2 months ago. Apr 06, 2019 - 09:17 PDT
Update
We are continuing to investigate this issue.
Posted about 2 months ago. Apr 06, 2019 - 08:44 PDT
Investigating
We are currently investigating this issue.
Posted about 2 months ago. Apr 06, 2019 - 08:42 PDT
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS, Edgenuity Student LMS, Edgenuity Login, PowerSpeak, UpSmart, MyPath).