Edgenuity LMS Login
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 19 days ago. May 03, 2018 - 17:35 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 19 days ago. May 03, 2018 - 17:17 PDT
Update
We are continuing to investigate this issue.
Posted 19 days ago. May 03, 2018 - 16:58 PDT
Investigating
We are currently investigating this issue.
Posted 19 days ago. May 03, 2018 - 16:57 PDT
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS, Edgenuity Student LMS, Edgenuity Login, SSO Login, Genius/SIS, PowerSpeak, eNotes, e-Rater, Videos, LMS feature/tool, LTI, UpSmart, MyPath).