Zendesk Service Unavailable
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Feb 08, 2021 - 06:59 MST
Monitoring
Our 3rd party vendor Zendesk has deployed a fix to resolve this issue; we are beginning to see some stability for the support system, our customer support team is now able to receive phone calls and chat messages.
Posted Feb 08, 2021 - 06:47 MST
Investigating
We are currently experiencing issues with our Zendesk service system. You may experience delays when trying to contact our support team.
Posted Feb 08, 2021 - 06:31 MST
This incident affected: General Edgenuity Systems (Edgenuity support line, Edgenuity chat service).