Not able to log onto Genius SIS
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Jul 09, 2019 - 13:20 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2019 - 13:14 EDT
Investigating
We are investigating an issue with our http://sislogin.edgenuity.com site. Educators and/or Students are unable to log onto Genius SIS.
Posted Jul 09, 2019 - 13:08 EDT
This incident affected: Student and Educator Systems (Genius/SIS).