SIS Slowness
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 16 days ago. Sep 04, 2019 - 23:28 EDT
Identified
Genius/SIS Educators continue experiencing slowness when searching for enrollments and/or students. Our 3rd party Genius has been notified and their team will be deploying adjustments to address the issue at 7:00pm Arizona time. The next update will be provided once the changes have been made.
Posted 17 days ago. Sep 04, 2019 - 18:10 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 17 days ago. Sep 04, 2019 - 14:28 EDT
Investigating
Reports of SIS users encountering slowness have been reported. We are currently working on reviewing and addressing this issue
Posted 17 days ago. Sep 04, 2019 - 12:46 EDT
This incident affected: Student and Educator Systems (Genius/SIS).