Edgenuity Login Error
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 17:55 MST
Update
We are continuing to investigate this issue.
Posted Oct 22, 2019 - 17:31 MST
Investigating
We are currently investigating this issue.
Posted Oct 22, 2019 - 17:17 MST
This incident affected: Student and Educator Systems (Edgenuity Student LMS, Edgenuity Login).