System Degraded
Incident Report for status.edgenuity.com
Resolved
Errors for students/teachers have been addressed and are back to full functionality. If you have any other questions or concerns, please e-mail customersupport@edgenuity.com
Posted 4 months ago. Jan 26, 2017 - 12:42 MST
Identified
Edgenuity is currently experiencing unexpected errors in some areas for both student and educators. Several teams are currently working to help resolve the issue as soon as possible. During this time, you may experience delays when contacting our customer support team.



If you have any other questions or concerns, please e-mail customersupport@edgenuity.com.



Thank you for your partnership,

The Edgenuity Team
Posted 4 months ago. Jan 26, 2017 - 12:23 MST
This incident affected: Student and Educator Systems (Teacher LMS, Student LMS).