Course Editions
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 08:06 MST
Identified
We are aware the some course editions are currently displaying incorrectly, and we are in the process of remedying this. We anticipate the data will be corrected very soon.
Posted Nov 12, 2019 - 16:39 MST