SIS LMS Access
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 21, 2018 - 11:52 EDT
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Jun 21, 2018 - 11:30 EDT
This incident affected: Student and Educator Systems (Genius/SIS).