Genius SIS Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Sep 07, 2021 - 09:03 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2021 - 14:23 MST
Investigating
The Genius SIS platform is currently in a degraded state.

Students and Educators may experience intermittent errors.

Our Operations team is currently engaged and investigating the issue. We apologize for the inconvenience and will provide an update as soon as possible.
Posted Sep 03, 2021 - 14:16 MST
This incident affected: Student and Educator Systems (Genius/SIS).