Edgenuity's Instance of Genius SIS Issues
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 06:39 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2020 - 06:35 MST
Investigating
Our team is investigating an issue with Edgenuity's instance Genius SIS causing some features to be unavailable. We are attempting to restore the functionality as our highest priority.
Posted Sep 10, 2020 - 06:11 MST
This incident affected: Student and Educator Systems (Genius/SIS).