Genius Accelerate Elementary Course Error
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 11:12 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 05, 2019 - 07:20 MST
This incident affected: Student and Educator Systems (Genius/SIS).