Slowness in the Genius platform
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Sep 03, 2020 - 14:08 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2020 - 12:54 MST
Investigating
We are currently investigating this issue.
Posted Sep 03, 2020 - 12:46 MST
This incident affected: Student and Educator Systems (Genius/SIS).