Edgenuity LMS Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 1 year ago. May 04, 2018 - 15:10 EDT
Update
We are continuing to investigate this issue.
Posted about 1 year ago. May 04, 2018 - 15:08 EDT
Investigating
Edgenuity is currently looking into reports of unexpected errors and is currently investigating this issue.
Posted about 1 year ago. May 04, 2018 - 14:25 EDT