Genius SIS Slowness
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Aug 17, 2020 - 10:26 MST
Investigating
We are currently investigating this issue.
Posted Aug 17, 2020 - 09:17 MST
This incident affected: Student and Educator Systems (Genius/SIS).