Browser Performance
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 02, 2018 - 07:45 MST
Identified
We have identified an issue of users having degraded perfornance when using Internet explorer.
Posted about 1 month ago. Nov 02, 2018 - 07:23 MST