Network Degraded
Incident Report for status.edgenuity.com
Resolved
Service has been restored for all Edgenuity users. Edgenuity is back to full operational status.

If you have any other questions or concerns, please e-mail customersupport@edgenuity.com.



Thank you for your partnership,

The Edgenuity Team
Posted 4 months ago. Feb 08, 2017 - 16:36 MST
Investigating
Edgenuity is currently experiencing network difficulties in some areas for both student and educators. Several teams are currently working to help resolve the issue as soon as possible. During this time, you may experience delays when contacting our customer support team.



If you have any other questions or concerns, please e-mail customersupport@edgenuity.com.



Thank you for your partnership,

The Edgenuity Team
Posted 4 months ago. Feb 08, 2017 - 15:36 MST
This incident affected: Student and Educator Systems (Teacher LMS, Student LMS).