Odyssey LMS Unavailable
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 8 months ago. Sep 10, 2017 - 18:57 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 8 months ago. Sep 10, 2017 - 17:54 PDT
Investigating
We are currently investigating this issue.
Posted 8 months ago. Sep 10, 2017 - 17:48 PDT
This incident affected: Student and Educator Systems (Odyssey LMS).