Phone System
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 20 days ago. Jul 02, 2019 - 10:29 EDT
Update
We are continuing to work on a fix for this issue.
Posted 20 days ago. Jul 02, 2019 - 10:17 EDT
Identified
This issue has been identified by our 3rd party provider, Zendesk. Calls are now intermittent as Zendesk are working to resolve this issue.
Posted 20 days ago. Jul 02, 2019 - 10:15 EDT
Investigating
We are currently investigating an issue where users are unable to connect calls to our customer support.
Posted 20 days ago. Jul 02, 2019 - 10:02 EDT
This incident affected: General Edgenuity Systems (Edgenuity support line, Edgenuity chat service).