Edgenuity SIS Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 26, 2018 - 06:29 MST
Update
We are continuing to investigate this issue.
Posted 3 months ago. Sep 26, 2018 - 05:42 MST
Update
We are continuing to investigate this issue.
Posted 3 months ago. Sep 26, 2018 - 05:37 MST
Investigating
Edgenuity is currently looking into reports of unexpected errors and is currently investigating this issue.
Posted 3 months ago. Sep 26, 2018 - 05:19 MST
This incident affected: Student and Educator Systems (Genius/SIS).