Odyssey Log in Error
Incident Report for status.edgenuity.com
Resolved
Issue has been resolved.

If you have any other questions or concerns, please e-mail customersupport@edgenuity.com
Posted 7 months ago. Mar 02, 2017 - 13:51 MST
Identified
Edgenuity students and teachers are experiencing difficulty with our Odyssey login page. We have multiple teams working to resolve this as soon as possible. During this time, you may experience delays when contacting our customer support team.


If you have any other questions or concerns, please e-mail customersupport@edgenuity.com



Thank you for your partnership,

The Edgenuity Team
Posted 7 months ago. Mar 02, 2017 - 13:43 MST
This incident affected: Student and Educator Systems (Odyssey).