Zendesk Service Outages
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 13, 2019 - 14:54 EDT
Update
We are continuing to work on a fix for this issue.
Posted about 1 month ago. Sep 13, 2019 - 13:05 EDT
Identified
We are currently experiencing issues with taking phone calls through the Zendesk service system. You may experience delays when trying to contact our support team.
Posted about 1 month ago. Sep 13, 2019 - 11:59 EDT
This incident affected: General Edgenuity Systems (Edgenuity support line).