Foreign Languages Recordings
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 10, 2018 - 12:36 MST
Identified
PowerSpeak user may experience unavailability when trying to access previously recorded files. Files/recording impacted are from May 1, 2018 – Oct. 9. 2018. This issue is only affecting Foreign Language users. Multiples teams are addressing this issue and it's our utmost priority.
Posted 2 months ago. Oct 10, 2018 - 05:53 MST
This incident affected: Student and Educator Systems (PowerSpeak).