Dashboard Refresh Date
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Oct 29, 2021 - 07:37 MST
Investigating
The Odysseyware platform is currently experiencing degraded performance.

Some educators may see the Reports Dashboard Refresh Date is not current.

Our Operations team has identified the issue and is currently implementing a solution. We apologize for the inconvenience and will provide an update as soon as possible.
Posted Oct 28, 2021 - 05:36 MST
This incident affected: Student and Educator Systems (Odysseyware LMS).