Intermittent Login Access
Incident Report for status.edgenuity.com
Resolved
Edgenuity login errors have been addressed and are back to full functionality. We apologize for any inconvenience this may have caused. If you have any other questions or concerns, please e-mail customersupport@edgenuity.com
Posted 4 months ago. Jan 27, 2017 - 10:37 MST
Investigating
Edgenuity is currently looking into reports of intermittent errors with learn.education2020.com Teams are currently working to help resolve this as soon as possible. During this time, you may experience delays when contacting our customer support team.


If you have any other questions or concerns, please e-mail customersupport@edgenuity.com



Thank you for your partnership,

The Edgenuity Team
Posted 4 months ago. Jan 27, 2017 - 09:57 MST
This incident affected: Student and Educator Systems (Login).