Powerspeak Network Issues
Incident Report for status.edgenuity.com
Resolved
PowerSpeak issues have been resolved and we expect services to gradually recover. We apologize for any disruptions this may have caused and appreciate your patience. Should you have any questions or concerns, please email: customersupport@edgenuity.com
Posted 9 months ago. Feb 28, 2017 - 14:55 MST
Monitoring
Edgenuity is fully operational however, Edgenuity is currently experiencing intermittent network issues in some Language/PowerSpeak courses. We are aware of the issue and are working to resolve it as quickly as possible.

If you have any questions or concerns, or are experiencing any other technical issues, please e-mail customersupport@edgenuity.com.



Thank you for your patience,

The Edgenuity Team
Posted 9 months ago. Feb 28, 2017 - 11:49 MST
This incident affected: Student and Educator Systems (PowerSpeak).