Edgenuity E-mail
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 12, 2018 - 10:45 MST
Identified
You may have received a message recently, or a series of messages, appearing to come from someone at Edgenuity. These messages have various subject headers and contain a green box that asks you to “Click here to show this message”. Do not click on this green box. These emails are not from Edgenuity.

Our IT department is currently investigating. Should you have any questions or experience any issues, please contact our Support Team at 877.202.0338 or CustomerSupport@edgenuity.com.
Posted 2 months ago. Oct 12, 2018 - 07:47 MST