Intermittent Issues with Zendesk
Incident Report for status.edgenuity.com
Resolved
Our 3rd party Zendesk was able to address the phone and chat issues. Thank you for your patience and understanding as we worked with our service provided. This incident has been resolved.
Posted Feb 08, 2021 - 13:39 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 08, 2021 - 09:51 MST
Investigating
We are currently experiencing issues with taking phone calls through the Zendesk service system. You may experience delays when trying to contact our support team.
Posted Feb 08, 2021 - 08:00 MST
This incident affected: General Edgenuity Systems (Edgenuity support line, Edgenuity chat service).