Issues Loading Edgenuity Courseware
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Sep 05, 2020 - 08:25 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 05, 2020 - 08:15 MST
Investigating
We are currently investigating this issue.
Posted Sep 05, 2020 - 08:06 MST
This incident affected: Student and Educator Systems (Edgenuity Student LMS).