Odyssey LMS Errors
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted Nov 25, 2020 - 07:23 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2020 - 07:16 MST
Investigating
Edgenuity is currently looking into reports of unexpected errors and is currently investigating this issue.
Posted Nov 25, 2020 - 06:14 MST
This incident affected: Student and Educator Systems (Odyssey LMS).