Edgenuity Intermittent LMS Features Tools
Incident Report for status.edgenuity.com
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 10, 2019 - 18:46 PDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Apr 10, 2019 - 18:21 PDT
This incident affected: Student and Educator Systems (Edgenuity Teacher LMS, LMS feature/tool, Genius/SIS, Videos, CloseReader, LTI, UpSmart, MyPath).