SIS log In
Incident Report for status.edgenuity.com
Resolved
Students trying to reach www.edgenuity.com/sis-login/ are now able to do so. Any students still having an issue trying to use the login, may visit edgenuity.com, as there is an alert posted with a redirect link. We apologize for any inconvenience.
Posted 3 months ago. Jan 07, 2017 - 13:10 MST
Investigating
We are currently looking into errors when trying to log in through edgenuity.com/sislogin. The issue is being addressed and will be rectified as soon as possible
Posted 3 months ago. Jan 07, 2017 - 12:04 MST
This incident affected: Student and Educator Systems (Genius/SIS).