Expired SSL Certificate for Odysseyware Academies (Genius/SIS)
Incident Report for status.edgenuity.com
Resolved
Our partners have implemented a fix that has restored access. Thank you for your patience as we worked to resolve this issue.
Posted Jun 16, 2021 - 18:31 MST
Update
The issue has been identified and we are working with our partners to implement a fix.

We apologize for the inconvenience and will provide an update as soon as possible.
Posted Jun 16, 2021 - 14:36 MST
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2021 - 14:33 MST
Update
We appreciate your patience as we scrutinize the cause for the issues reported earlier. Our operations team is working to implement a fix, and we will provide further details when they become available.
Posted Jun 16, 2021 - 14:15 MST
Identified
The Odysseyware Academy platform is currently experiencing an outage.

Students may have difficulty accessing the academy through a private connection.

Educators may have difficulty accessing the academy through a private connection.

Our Operations team has identified the issue and is currently preparing a solution. We apologize for the inconvenience and will provide an update as soon as possible.
Posted Jun 16, 2021 - 13:33 MST
This incident affected: Student and Educator Systems (Odysseyware LMS).